Elevated errors on MCP and Connector
Monitoring·Partial outage

We have implemented mitigation steps to address the increased error rates affecting MCP and connector services, Agents and Workflows. System performance is stabilizing, and we are actively monitoring all impacted components to ensure full recovery.

Users may still experience minor intermittent issues as we continue to validate the fixes. We will provide further updates once we confirm complete resolution.

Thank you for your continued patience.

Tue, Mar 3, 2026, 02:23 PM
(1 hour ago)
·
Affected components
Website
App
Connectors & MCP
Custom Agents and Workflows
Updates

Monitoring

We have implemented mitigation steps to address the increased error rates affecting MCP and connector services, Agents and Workflows. System performance is stabilizing, and we are actively monitoring all impacted components to ensure full recovery.

Users may still experience minor intermittent issues as we continue to validate the fixes. We will provide further updates once we confirm complete resolution.

Thank you for your continued patience.

Tue, Mar 3, 2026, 02:23 PM

Monitoring

We have implemented mitigation steps to address the increased error rates affecting MCP and connector services. System performance is stabilizing, and we are actively monitoring all impacted components to ensure full recovery.

Users may still experience minor intermittent issues as we continue to validate the fixes. We will provide further updates once we confirm complete resolution.

Thank you for your continued patience.

Tue, Mar 3, 2026, 01:43 PM(39 minutes earlier)

Identified

We have identified an increase in error rates affecting MCP and connector services. Our engineering team is actively investigating the root cause and working on a fix.

Users may experience intermittent failures or degraded performance when using MCP-related features and external connectors. We will continue to provide updates as we make progress.

Thank you for your patience while we resolve this issue.

Tue, Mar 3, 2026, 12:20 PM(1 hour earlier)